DiamondFire Updates

DiamondFire is now running Minecraft 1.10!

Originally, this update was going to take longer due to waiting for outside plugins.  I ended up going through the trouble of updating one of those plugins myself (which took a while) so that we could get the update out faster!

You may have seen some 1.9/1.10 compatible servers running a special protocol hack.  The protocol hack does not let you use any of the new 1.10 features.  DiamondFire is running full 1.10 - so while you can't connect on 1.9, you can use all the awesome 1.10 features like polar bears!

In addition to the update, there's a new patch adding a few new pets, new creator levels, and a cool lucky voting mechanic!

Enjoy!

- Jeremaster

Login to DiamondFire
Online users (1)
Latest Threads
NoticeNotices